Emagic Synth Collection with ES1, ES2, and EVOC20

No longer available at zZounds
ES2 System Requirements

Minimum:
Logic or MicroLogic AV Version 5
Mac OS 9.1 or higher
G3/400
128 MB RAM or more
CD ROM or DVD drive

Recommended:
CPU with Velocity Engine support (G4/MP)
256 MB RAM or more
Low-latency audio hardware
MIDI interface, MIDI keyboard

EVOC20 System Requirements

Minimum:
Logic or MicroLogic AV Version 5
Mac OS 9.1 or higher
G3/400
128 MB RAM or more
CD ROM or DVD drive

Recommended:
CPU with Velocity Engine support (G4/MP)
256 MB RAM or more
Low-latency audio hardware
MIDI interface, MIDI keyboard

ES1 System Requirements

Minimum:
Logic Audio/MicroLogic AV 4.1* or higher
604/200 MHz processor
Mac OS 8.6
USB requires Mac OS 9.0.4
64 MB RAM
CDROM drive

For ES1 TDM: Logic Audio Platinum from 4.5.1*, min. one free DSP of a Digidesign ProTools/24 Mix Core/Farm card. Consult the Digidesign TDM system requirements for further information.

* All necessary updates for Logic Audio 4.x are included on the program CD.

Recommended:
G3 or G4 Processor
128 MB RAM
Digital audio card
MIDI interface

No longer available at zZounds

In most cases, a product is unavailable because it has been discontinued by the manufacturer

Shipping to
💬
Chat With Us